VMware Cloud Provider

Usage Meter 4.1 & 4.2 Functional Support Ending July 5, 2022.

What’s happening?

Usage Insight service is decommissioning the cloud service components used for ingestion and processing of older Usage Meter 4.1 and 4.2 agents. This means that any partner using Usage Meter 4.1 or Usage Meter 4.2 will no longer be able to meter, upload, and process usage into a Monthly Usage Report.

Why is this happening?

As the Usage Insight service continues to build and enhance on user/partner needs, it becomes apparent that there are components that need to change or be rebuilt. VMware came to this crossroad last year as we started working on some future enhancements. We tried to extend this functional support for as long as possible, but Usage Insight is at a point where these older components are now blocking future work. Due to these blockers, extended functional support for Usage Meter 4.1 and 4.2 must end so that Usage Insight can keep enhancing.

When is this happening?

The end of Functional support will happen on July 5th, 2021. This allows any Usage Meter 4.1 or 4.2 appliance to still be used for the June Monthly Billing Order, which is available in July.

How to tell if I am affected?

There are two ways to see what version you are running:

  1. Login to the Usage Meter appliance, go to the top right and click on the user icon, then click “About”.
  2. Login to Cloud Partner Navigator, then download a copy of a monthly usage report. All reports contain the Usage Meter version.

Alternatively, you could look for emails from VMware stating that Usage Meter 4.1 and 4.2 are going End of Support. Emails are being sent to partners still running these versions daily based on users in the Navigator organizations.

What do I need to do?

Not much, really; just perform an in-place upgrade from Usage Meter 4.1/4.2 to Usage Meter 4.5.0.1. The following information will help you perform the in-place upgrade. The upgrade files can be downloaded from here. Before the upgrade, you can check which products and versions are metered by Usage Meter 4.5 in the VMware Interoperability Matrix. For Usage Meter 4.1, after the upgrade, you will need to manually accept the product certificates in the Usage Meter web application.

What If I do nothing?

Partners that fail to upgrade to a supported version of Usage Meter (as is required in VCPP) are considered out of technical compliance and will not have a monthly usage report generated. This means that automatic reporting will cease to function. Partners are required to run supported versions of Usage Meter according to the program guide.

Licensing compliance will be reaching out to these partners directly as part of a compliance review due to running unsupported versions of Usage Meter.

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *