NSX Product News Software Defined Data Center

VMware NSX Customer Advisory – January 2018

In this communication, we detail the top trending issues with VMware NSX for vSphere and provide you with helpful information on how to address the issues while we build a permanent fix. Please review the left column of the chart below to search for issues specific to your environment, and click on the hyperlinks to access more detailed information on each.

For up-to-date Top Trending NSX issues, previous and current, please see KB Article Trending support issues in VMware NSX for vSphere 6.x (2131154).

 

Spotlight Issues

Affected version Component Issue Summary Resolution/Work-Around KB Number
6.2.x
6.3.x
6.4.x
Guest Introspection VMware NSX Guest Introspection compatibility for Microsoft Windows patches released for “Spectre” and “Meltdown”. With the testing conducted for various versions of Microsoft Windows where patches are available, no issues are reported. VMware NSX Guest Introspection is compatible with these patches. KB: 52292
6.3.3 Controller At times certain controller APIs could fail due to cleanup of API server reference files. This issue is resolved in VMware NSX for vSphere 6.3.4.

To work around the issue on NSX for vSphere 6.3.3, and to avoid encountering this issue while upgrading from NSX for vSphere 6.3.3 to a later version, VMware developed a signed script that recreates the status file required by the API server.

KB: 2151719
6.3.x Edge/ DLR Modifying the interface configuration for an already deployed DLR/ESG fails with a blank error message. This issue is resolved in VMware NSX for vSphere 6.3.3.

To work around this issue if you do not want to upgrade, use REST API to configure/edit the interface settings for the attached releases.

KB: 2151153 
6.3.3
6.3.4
Controller Deploying NSX Controller fails in NSX-v 6.3.3 and 6.3.4 due to the photon based Controllers which has been set with a default 90 day password expiration. The issue is resolved in the updated/reposted NSX for vSphere 6.3.3, 6.3.4 releases.
As a workaround for the existing NSX-v 6.3.3/6.3.4 deployments, and to avoid encountering this issue while upgrading to newer versions of NSX for vSphere, VMware developed a signed script that sets the password for user accounts on the Controller to never expire and if the password has already expired, it will reset the password to the one set by user during initial Controller deployment.
KB: 51144

 

GA Announcement

VMware NSX for vSphere 6.4.0 | Build 7564187 was released on January 16, 2018 and is now available for download. It includes features like Deepening micro-segmentation use case (RDSH); L7 firewall, Improving Ease-of-Use and Serviceability using Upgrade Coordinator, Capacity and Troubleshooting Dashboards etc., Core Feature Enhancements like VPN routing over GRE, NAT64, CDO etc, and Quality Improvements and product hardening.
 
NOTE: vSphere 5.5 is not supported with NSX-v 6.4.0 IMPORTANT: NSX-v 6.4.0 supports ESXi 6.0 U2 and above. Customers running ESXi 5.5 or lower must upgrade to ESXi 6.0 U2 or higher prior to updating to NSX-v 6.4.0. For more information, see the VMware Product Interoperability Matrices.

  • For vSphere 6.0:
    • Supported:  6.0 Update 2, 6.0 Update 3
    • Recommended:  6.0 Update 3, vSphere 6.0 Update 3 resolves the issue of duplicate VTEPs in ESXi hosts after rebooting     vCenter Server.
    • See VMware Knowledge Base article 2144605 for more information.
  • For vSphere 6.5:
    • Supported: 6.5a, 6.5 Update 1
    • Recommended: 6.5 Update 1 vSphere 6.5 Update 1 resolves the issue of EAM failing with OutofMemory.
    • See VMware Knowledge Base Article 2135378 for more information.

For more information, see the VMware NSX for vSphere 6.4.0 Release Notes and NSX Documentation page.

 

Don’t Forget!

Subscribe to my.vmware.com to get timely notifications on NSX Product Releases, Fixes and upcoming patches.

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *