Home > Blogs > Support Insider


Running older versions of Virtual Machine Tools on newer versions of ESX hosts

We have received several requests from customers asking us to clarify our support status of running older versions of Virtual Machine Tools on newer versions of ESX hosts. To help clear up any confusion we are now stating this:

It is strongly recommended that the version of VMware Tools running in the VM match the version of ESX/ESXi on which the VM is running. It is also recommended that after ESX/ESXi is upgraded, that  VMware Tools in all the VMs on that host be upgraded at the earliest opportunity. VMware Global Support Services (GSS) will assist customers even if they have mismatched versions of Tools and ESX/ESXi, however GSS may require that the appropriate version of Tools be installed in the guest if GSS suspects that the mismatched version of Tools may be contributing to the issue being reported, if it makes debugging the issue easier or for any other reason.