General

New Release: PowerCLI 10.2.0

It’s new release day! Even though we’re counting down the days to VMworld, we still have a fresh version for you with PowerCLI 10.2.0!

Speaking of counting, this marks the 4th release of PowerCLI this year. I remember when getting 2 updates in a single year was a major event, much less four! A big shout-out to the PowerCLI engineering team for all the work that’s been done to make this process faster and easier. If you’d like to know more details, VMworld session DEV3504BU will take an in-depth look at the PowerCLI development process. It’s a session I’m super excited for!

On to the updates!

PowerCLI 10.2.0 Updates

PowerCLI 10.2.0 comes with the following updates:

  • Support for NSX-T 2.2
  • Deprecation of the PCloud module, so look for this module to be removed in the future
  • Update to Get-VIEvent to resolve the issue when receiving: Error in deserializing body of reply message for operation ‘RetrieveProperties’

For more information on changes made in VMware PowerCLI 10.2.0, including improvements, security enhancements, and deprecated features, see the VMware PowerCLI Change Log. For more information on specific product features, see the VMware PowerCLI 10.2.0 User’s Guide. For more information on specific cmdlets, see the VMware PowerCLI 10.2.0 Cmdlet Reference.

Remember, updating your PowerCLI modules is now as easy as ‘Update-Module VMware.PowerCLI’.

Update-Module VMware.PowerCLI

Comments

12 comments have been added so far

  1. I cant seem to figure out how to install 10.2.0 when i did a fresh install “Install-Module -Name VMware.PowerCLI” Version 10.1.0 installed. I tried Update-Module and nothing seems to happen. When i do Get-Module , the version reported is 10.1.0.8377811

    not sure what im doing wrong here.

    1. Were you actively using PowerCLI in that PowerShell session prior to the update?
      If yes, then closing and re-opening PowerShell should give you access to 10.2.0.
      If no, try running ‘Find-Module VMware.PowerCLI’ and see if you can find 10.2.0.

      You’re also more than welcome to open a VMware Support ticket.

    1. Certainly, there’s no requirement to keep the old version of the modules around.

      One thing to keep in mind, these updates to PowerCLI 10.x.x are incremental in nature. That means every module won’t be on version 10.2.0, only the ones that have been updated.

  2. Hey,

    I was trying out few things with VUM, can you or anyone please suggest what is the way to perform the VUM operations programmatically (without PowerCLI) as i couldn’t find any APIs or SDKs exposed by VMware yet.

    Thanks
    Ayush

  3. Hi Kyle,

    I am facing an issue modifying CPU / RAM values of civm since 10.0.x. However little to no information is available on how to resolve this, could you help me out :)?

    PS C:\WINDOWS\system32> $vm.ExtensionData.Section[0].item[7].VirtualQuantity.Value = 5
    PS C:\WINDOWS\system32> $vm.ExtensionData.Section[0].UpdateServerData()
    Exception calling “UpdateServerData” with “0” argument(s): “Argument ‘uriTemplate’ must not be null.
    Parameter name: uriTemplate”
    At line:1 char:1
    + $vm.ExtensionData.Section[0].UpdateServerData()
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : CloudException

    Thanks in advance!

  4. Please also update offline zip install bundle located here https://code.vmware.com/web/dp/tool/vmware-powercli/10.2.0

    It does not auto-load module when extracted. This is the only way I can currently get PowerCLI installed on my local machine due “Security” restrictions preventing ANY software install from online unless approved. Yes, I know, save-module, we have tried that as well. Yes, we have tried everything 🙂

    Appreciate your assistance on code.vmware updated.

  5. I have a Ubuntu 16.04 vm that I would like to run powercli on it. I found instruction on how to install powershell on Ubuntu 16.04, but can’t find anything for powercli. Is there anything written up on how to do this?

Leave a Reply

Your email address will not be published. Required fields are marked *